الإعــلام الآلي والرياضيــات يشتمل على جميع مبادئ الإعلام الآلي والرياضيــات

إضافة رد
قديم 16-01-2008, 03:28 PM
  #1
Encrypted
 الصورة الرمزية Encrypted
 
تاريخ التسجيل: 25-10-2007
الدولة: DZ
المشاركات: 147
Encrypted عضو يستحق التميز
Exll الخوارزميات (Les Algorithmes)


السلام عليكم

الكل منا يسمع عن لغات البرمجة

و الكل يعرف أنها مجموعة من الأوامر توصلنا لغاية ما

و لكن قلة فقط تعرف أن كل هذه اللغات أصلها الخوارزميات

حيث أن الخوارزمية هو أيضا مجموعة من الأوامر مثل كل لغات البرمجة الأخرى

و الفرق بينها و بينه أنه يكتب على ورق و ليس على الحاسوب

فأي مبرمج يريد صنع برنامج يكتب أولا خوارزمية ثم يستبدل أوامر اللوغ بأوامر أي لغة برمجة يريد ليضعها على الحاسوب


و قبل الدخول في التعقيدات يجب علينا معرفة مراحل عمل برنامج ما

في عالم المعلوماتية يوجد ثلاث أطراف للحوار :

-المستخدم : هو الشخص الذي يواجه مشكلا و يطلب المساعدة من الحاسوب

حيث أن المستعمل يرى في حاسوب مزود بالبرنامج المناسب أداة لتسيير أعماله فهدفه إذن هو تعلم الاستخدام الأفضل لهذه الأداة .

-المبرمج : و هو الشخص القادر على توجيه الحاسوب في حل المشاكل التي يضعها المستخدم فالحاسوب بالنسبة للمبرمج هو منفد للأوامر يجب توجيهه .

-الحاسوب : الذي لا يعرف سوى تنفيذ الأوامر فيكفي أن يكون البرنامج سليما من حيث الكتابة ليقوم بكل ما هو مطلوب منه .

تعريف الخوارزمية


الخوارزمية هي متتالية منتهية من التعليمات تبين الطريقة التي بها يتم تنفيذ مجموعة من العمليات للحصول على حل لمشكل ما .


و الآن ندخل صلب الموضوع

و بالنسبة للأوامر سأعطيها باللغة الفرنسية (في الجزائر نستخدم هذه اللغة وأنا حقيقة أكرهها ) فليعذرني كل من لا يتكلمها و لكن طريقة وضعها هي نفسها بالإنجليزية أيضا فتكفي الترجمة .

للخوارزمية ستة أركان أساسية سوف نتحدث عن الخمسة الأساسية (لم ندرس الركن السادس بعد )

أولا المتغيرات

المتغير عبارة عن علبة يعرفها البرنامج بواسطة علامة توضع عليها فلكي يدخل البرنامج إلى محتوى العلبة يكفي الإشارة إليها بعلامتها

الإعلان عن المتغيرات

أول شيء يجب فعله قبل استعمال متغير ما هو إنشاء العلبة و أعطاؤها علامة

عندما نريد الإعلان عن متغير ما لا يكفي إنشاء العلبة و إنما يجب تحديد نوعية المحتوى

طريقة الكتابة

متغير = var

و يتم التعبيرعن نوعية المحتوى كالتالي

كلمات = Chaine de caracteres

أعداد صحيحة طبيعية = entier

أعداد حقيقية = reel

صحيح أو خطأ = booleen

و هناك أخرى و لكن هذه هي الأساسية بالنسبة لمبتدئ

مثال

Var a : entier

Var a : Chaine de caractere


إعطاء قيمة للمتغير

يتم الإعلان عن قيمة متغير ما باستعمال السهم المعكوس

مثال


ALGO Valeurs

Var a,b,c : entiers

Début

a <-- 3

b <-- 10

c <-- a+b

b <-- a-b

a <-- c

Fin


بعد تنفيد الأوامر المطلوب هو إيجاد قيم a و b و c
نبدأ ب c:
c <-- a+b
c <-- 10+3
c <-- 13

ثم b
b <-- a-b
b <-- 3-10
b <-- -7

ثم a
a <-- c
a <-- 13


فنجد أن القيم هي

a : 13, b : -7, c : 13

ثانيا أوامر القراءة و الكتابة

يستعمل أمر الكتابة (Ecrire) لكتابة رسالة تدل المستعمل على ما يحدث

و يستعمل أمر القراءة (Lire) لجعل الحاسوب يتوقف في مرحلة ما إلى حين إدخال المستعمل لقيمة يقرؤها الحاسوب



مثال

عددا ما حتى يعطينا مربعه

ALGO Carré

Var a,b : entiers

Début

("Ecrire (" Donner un nombre

(Lire (a

B <-- a*a

(Ecrire (" Le carré est ",b


ثالثا صيغ الشرط

تتلخص صيغ الشرط في إعطاء شرط إجباري لتنفيذ عملية ما

طريقة الكتابة

Si condition = vrai Alors

Instruction 1

Sinon

Instruction 2

Fin Si


المثال الأول : مقارنة a مع b واعطاء القيمة الأكبر


ALGO Maximum

Var a,b,Max : entiers

Début

("Ecrire (" Entrez le premier nombre

(Lire (a

("Ecrire (" Entrez le deuxième nombre

(Lire (b

Si a>b Alors

Max <-- a

Sinon

Max <-- b

Fin Si

(Ecrire (" Le Maximum est : ",Max

Fin


المثال الثاني

نفس المثال الأول و لكن هذه المرة بثلاث أعداد

ALGO Maximum

Var a,b,c,Max : entiers

Début

("Ecrire (" Entrez le premier nombre

(Lire (a

("Ecrire (" Entrez le deuxième nombre

(Lire (b

("Ecrire (" Entrez le troisième nombre

(Lire (c

Si a>b Alors

Max <-- a

Sinon

Max <-- b

Fin Si

Si Max<c Alors

Max <-- c

Fin Si

(Ecrire (" Le Max est : ",Max

Fin


المثال الثالث




ALGO Max & Min

Var a,b,c,Max,Min : entiers

Début

("Ecrire (" Entrez le premier nombre

(Lire (a

("Ecrire (" Entrez le deuxième nombre

(Lire (b

("Ecrire (" Entrez le croisième nombre

(Lire (c

Si a>b Alors

Max <-- a

Min <-- b

Sinon

Max <-- b

Min <-- a

Fin Si

Si Max<c Alors

Max <-- c

Fin Si

Si Min>c Alors

Min <-- c

Fin Si

(Ecrire (" Le Max est : ",Max

(Ecrire (" Le Min est : ",Min

Fin


المثال الرابع : حساب المعدل

العربية معاملها 3

الرياضيات معاملها 4

اللغة الأجنبية و معاملها 2


ALGO Moyaine Générale

Var a,b,c,MG : Réels

Debut

("Ecrire (" Entrez la note du Math

(Lire (a

("Ecrire (" Entrez la note de la langue arabe

(Lire (b

("Ecrire (" Entrez la note de la langue étrangère

(Lire (c

(MG <-- [(a*4)+(b*3)+(c*2)]/(4+3+2

(Ecrire (" La moyaine générale est : ",MG

Si MG<10 Alors

("Ecrire (" Eliminé

Sinon

Si MG<12 Alors

("Ecrire (" Passable

Sinon

Si MG<14 Alors

("Ecrire (" Assez Bien

Sinon

Si Mg<16 Alors

("Ecrire (" Bien

Sinon

("Ecrire (" Très Bien

Fin Si

Fin Si

Fin Si

Fin Si

Fin



رابعا الروابط المنطقية

تحت تصرفنا أربع عوامل أو روابط منطقية و هي ET و OU و NOT و XOR

و سنهمل NOT و XOR لأنها ذات مستوى مرتفع قليلا

طريقة عمل هذه الروابط هي كالتالي

إذا كان A=Vrai فإن NOT A=Faux

و العكس بالعكس

إذا كان A=Vrai, B=Faux فإن A ET B=Faux

إذا كان A=Faux, B=Vrai فإن A ET B=Faux

إذا كان A=Vrai, B=Vrai فإن A ET B=Vrai

إذا كان A=Faux, B=Faux فإن A ET B=Faux

إذا كان A=Vrai, B=Faux فإن A OU B=Vrai

إذا كان A=Faux, B=Vrai فإن A OU B=Vrai

إذا كان A=Vrai, B=Vrai فإن A OU B=Vrai

إذا كان A=Faux, B=Faux فإن A OU B=Faux

مثال

لدينا الخوارزمية التالية


ALGO Opérations Logiques

Var a,b,c,d,e : booleen

Var x : entier

Début

("Ecrire (" Introduire un nombre

(Lire (x

A <-- x<2

B <-- x>12

C <-- x<6

D <-- (a ET b) OU c

(E <-- a ET (b OU c

(Ecrire (" La valeur de d est : ", d

(Ecrire (" La valeur de e est : ",e

Fin

نفترض أن x=14

علينا معرفة قيمة dو e هل هي صحيحة أم خاطئة
هذا ما سنحصل عليه

d <-- F

e <-- F


خامسا الحلقات

لدينا عملية تتكرر سيكون من المتعب إعادة كتابتها و هنا نلجأ إلى الحلقات

هناك ثلاث طرق أساسية لإنشاء الحلقات

الحلقة TANTQUE

طريقة الكتابة


TANTQUE condition Faire

Action

Fin TANTQUE



مادام الشرط قائما سيستمر البرنامج في تكرار العملية إلى أن ينعدم الشرط

مثال

بمعرفة اسم الشهر من رقمه


ALGO Mois

Var m : entier

Début

("Ecrire (" Donner le N° du mois

(Lire (m

TANTQUE m<1 OU m>12 Faire

("Ecrire (" Erreur, Donner un nombre entre 1 et 12

(Lire (m

Fin TANTQUE
.
.
.
.
Fin




الحلقة Répeter

لها نفس الدور و لكن باتجاه معاكس


طريقة الكتابة

Répeter

Action

Jusqu'à




مثال

نرجع لمثال الأشهر

Répeter

("Ecrire (" Donner le N° du mois

(Lire (m

Jusqu'à m>1 ET 12>m


الحلقة POUR

هي الأكثر سهولة و الأكثر تعقيدا في الوقت نفسه


طريقة الكتابة


POUR i allant de Vi à Vf Faire

Action

Fin POUR






مثال


كتابة خولرزمية لحساب المجموع

S=1+2+3+4+......+20


ALGO Somme

Var i,s : entiers

Début

S <-- 0

POUR i allant de 1 à 20 Faire

S <-- s+i

Fin POUR

(Ecrire (" La Somme est : ",s

Fin

أرجو من من لديه معلومات أن يكمل الفقرة الخاصة بالجداول .


__________________
-------------------------------------
Encrypted غير متواجد حالياً  
رد مع اقتباس
قديم 17-01-2008, 05:01 PM
  #2
Zenini
VIP_MEMBRE
 الصورة الرمزية Zenini
 
تاريخ التسجيل: 22-10-2007
المشاركات: 220
Zenini عضو يستحق التميزZenini عضو يستحق التميز
افتراضي

بارك الله فيك كنت ابحث عن هذا الموضوع
Zenini غير متواجد حالياً  
رد مع اقتباس
قديم 18-01-2008, 01:48 AM
  #3
The AnalysT
VIP_MEMBRE
مشرف سابق
 الصورة الرمزية The AnalysT
 
La spécialité: Informatique
اخرى ( جامعة عربية او اجنبية )
تاريخ التسجيل: 11-11-2007
الدولة: الجلفة
المشاركات: 518
The AnalysT عضو محترف الابداعThe AnalysT عضو محترف الابداعThe AnalysT عضو محترف الابداعThe AnalysT عضو محترف الابداعThe AnalysT عضو محترف الابداعThe AnalysT عضو محترف الابداعThe AnalysT عضو محترف الابداع
افتراضي

بارك الله فيك اخي الكريم على الموضوع القيم

الله لا يحرمنا منك يا مبدع

لك احترامي
__________________
اللهم إنك عفو كريم تحب العفو فأعفو عنا
The AnalysT غير متواجد حالياً  
رد مع اقتباس
قديم 24-01-2008, 09:04 PM
  #4
Encrypted
 الصورة الرمزية Encrypted
 
تاريخ التسجيل: 25-10-2007
الدولة: DZ
المشاركات: 147
Encrypted عضو يستحق التميز
افتراضي

وفيك بركة ، شكرا على الردود ، و أعتذر عن الانقطاع بسبب الدراسة .
Encrypted غير متواجد حالياً  
رد مع اقتباس
قديم 22-02-2008, 06:39 PM
  #5
ward
VIP_MEMBRE
 الصورة الرمزية ward
 
تاريخ التسجيل: 26-10-2007
المشاركات: 1,157
ward عضو محترف الابداعward عضو محترف الابداعward عضو محترف الابداعward عضو محترف الابداعward عضو محترف الابداعward عضو محترف الابداع
افتراضي

بارك الله فيك اخي على الموضوووووووووووع القيم
ششششششششششششششششششششكرا
ward غير متواجد حالياً  
رد مع اقتباس
قديم 05-04-2008, 11:02 AM
  #6
Elhachmivb
 الصورة الرمزية Elhachmivb
 
تاريخ التسجيل: 02-04-2008
المشاركات: 56
Elhachmivb عضو يستحق التميز
افتراضي

ممتاز waeel موفق إن شاء الله، ننتظر الركن السادس
Elhachmivb غير متواجد حالياً  
رد مع اقتباس
قديم 15-05-2008, 02:39 PM
  #7
mimik
 الصورة الرمزية mimik
 
La spécialité: Autres
جامعة عبد الحق بن حمودة جيجل
تاريخ التسجيل: 12-05-2008
الدولة: الجزائر
المشاركات: 1,607
mimik عضو محترف الابداعmimik عضو محترف الابداعmimik عضو محترف الابداعmimik عضو محترف الابداعmimik عضو محترف الابداعmimik عضو محترف الابداعmimik عضو محترف الابداعmimik عضو محترف الابداعmimik عضو محترف الابداعmimik عضو محترف الابداعmimik عضو محترف الابداع
افتراضي

بارك الله فيك هل لديك تمارين حول les procedure
mimik غير متواجد حالياً  
رد مع اقتباس
قديم 05-08-2008, 11:21 PM
  #8
ainisser2008
VIP_MEMBRE
مشرف سابق
 الصورة الرمزية ainisser2008
 
تاريخ التسجيل: 23-07-2008
الدولة: الجزائر
المشاركات: 599
ainisser2008 عضو يستحق التميزainisser2008 عضو يستحق التميزainisser2008 عضو يستحق التميزainisser2008 عضو يستحق التميز
افتراضي

بارك الله فيك اخي على الموضوووووووووووع القيم
ششششششششششششششششششششكرا
ainisser2008 غير متواجد حالياً  
رد مع اقتباس
قديم 01-11-2008, 04:46 PM
  #9
bahaa992
 
تاريخ التسجيل: 28-10-2008
المشاركات: 3
bahaa992 عضو يستحق التميز
افتراضي

</div></div>
bahaa992 غير متواجد حالياً  
رد مع اقتباس
قديم 17-11-2008, 11:24 AM
  #10
nabiljtm
 
تاريخ التسجيل: 17-11-2008
المشاركات: 1
nabiljtm عضو يستحق التميز
افتراضي

سلام.شكرا على التوضيحات.ونتمنى تمدنا ببرامج كيفية حساب الدالات.شكرا
nabiljtm غير متواجد حالياً  
رد مع اقتباس
إضافة رد

أدوات الموضوع
انواع عرض الموضوع

تعليمات المشاركة
لا تستطيع إضافة مواضيع جديدة
لا تستطيع الرد على المواضيع
لا تستطيع إرفاق ملفات
لا تستطيع تعديل مشاركاتك

BB code is متاحة
كود [IMG] متاحة
كود HTML معطلة

الانتقال السريع

المواضيع المتشابهه
الموضوع كاتب الموضوع المنتدى مشاركات آخر مشاركة
كتاب الخوارزميات achraf.mouni الإعــلام الآلي والرياضيــات 5 13-12-2011 11:58 AM
الخوارزميات «algorithm» يوسف الضادي المقالات العلمية : انشر مقالتك العلمية 14 08-12-2011 02:31 PM
Scribd: شرح وتعليم الخوارزميات WADDAH منتــدى البرمجــة العـــام 3 10-10-2009 02:25 PM
كيفية تصميم الخوارزميات achraf.mouni الإعــلام الآلي والرياضيــات 3 16-01-2009 11:35 AM
أساسيات برمجية للتعامل مع الخوارزميات MiMoO_Tz منتــدى البرمجــة العـــام 8 03-12-2008 03:59 PM


الساعة الآن 05:09 AM.